summaryrefslogtreecommitdiff
path: root/_dbus_glib_bindings/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2012-07-04 12:17:10 +0100
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2012-07-05 11:53:02 +0100
commit5558ee11313fd929ed6aeb22228e89de2263e520 (patch)
tree6d5d729a282ea28ba436be8fe643ed8ad8180dde /_dbus_glib_bindings/Makefile.am
parentec2671485a23090c470180eb297e67b86638d9b5 (diff)
downloaddbus-python-5558ee11313fd929ed6aeb22228e89de2263e520.tar.gz
Link Python extensions differently on Windows
Diffstat (limited to '_dbus_glib_bindings/Makefile.am')
-rw-r--r--_dbus_glib_bindings/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/_dbus_glib_bindings/Makefile.am b/_dbus_glib_bindings/Makefile.am
index 48af169..ead49da 100644
--- a/_dbus_glib_bindings/Makefile.am
+++ b/_dbus_glib_bindings/Makefile.am
@@ -11,5 +11,19 @@ libadd = \
$(DBUS_GLIB_LIBS) \
$(NULL)
+if WINDOWS
+# Win32 DLLs can't have undefined symbols (so this needs explicit linking
+# against the Python DLL), and Python expects extensions to be *.pyd
+# instead of *.dll
+AM_LDFLAGS += \
+ -no-undefined \
+ -shrext ".pyd" \
+ $(NULL)
+
+libadd += \
+ $(PYTHON_LIBS) \
+ $(NULL)
+endif
+
_dbus_glib_bindings_la_LIBADD = $(libadd)
_dbus_glib_bindings_la_SOURCES = module.c