summaryrefslogtreecommitdiff
path: root/_dbus_bindings/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2012-07-04 12:15:16 +0100
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2012-07-05 11:53:00 +0100
commitec2671485a23090c470180eb297e67b86638d9b5 (patch)
tree1646179bf028cf01523b89f90c5274652497355b /_dbus_bindings/Makefile.am
parent9c02d05642c8f99e3fe61804bcc33df380ebd5b1 (diff)
downloaddbus-python-ec2671485a23090c470180eb297e67b86638d9b5.tar.gz
Replace incorrect AM_LDFLAGS usage with a proper AM_LDFLAGS/LIBADD split
Diffstat (limited to '_dbus_bindings/Makefile.am')
-rw-r--r--_dbus_bindings/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/_dbus_bindings/Makefile.am b/_dbus_bindings/Makefile.am
index 2a5ec28..e0fb889 100644
--- a/_dbus_bindings/Makefile.am
+++ b/_dbus_bindings/Makefile.am
@@ -3,7 +3,11 @@ pyexec_LTLIBRARIES = _dbus_bindings.la
AM_CPPFLAGS = -I$(top_srcdir)/include $(DBUS_CFLAGS) $(PYTHON_INCLUDES)
AM_LDFLAGS = -module -avoid-version \
-export-symbols-regex \(PyInit__\|init_\)dbus_bindings \
- $(DBUS_LIBS)
+ $(NULL)
+
+libadd = $(DBUS_LIBS)
+
+_dbus_bindings_la_LIBADD = $(libadd)
_dbus_bindings_la_SOURCES = \
abstract.c \
bus.c \