summaryrefslogtreecommitdiff
path: root/_dbus_bindings/Makefile.am
diff options
context:
space:
mode:
authorBarry Warsaw <barry@python.org>2011-12-15 06:57:21 -0500
committerBarry Warsaw <barry@python.org>2011-12-15 06:57:21 -0500
commit4c1c2eade1c5b383adad94a7a4fd6553873fecf0 (patch)
treeb9e0f45fc19539bcaddff69e661bf0c5d21bab5a /_dbus_bindings/Makefile.am
parent667082d0b4aef9c438a2e7fec89614b5b8ef960a (diff)
downloaddbus-python-4c1c2eade1c5b383adad94a7a4fd6553873fecf0.tar.gz
This is the big one; it adds Python 3 support.
Diffstat (limited to '_dbus_bindings/Makefile.am')
-rw-r--r--_dbus_bindings/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/_dbus_bindings/Makefile.am b/_dbus_bindings/Makefile.am
index 891b35d..02d2ce0 100644
--- a/_dbus_bindings/Makefile.am
+++ b/_dbus_bindings/Makefile.am
@@ -1,7 +1,8 @@
pyexec_LTLIBRARIES = _dbus_bindings.la
AM_CPPFLAGS = -I$(top_srcdir)/include $(DBUS_CFLAGS) $(PYTHON_INCLUDES)
-AM_LDFLAGS = -module -avoid-version -export-symbols-regex init_dbus_bindings \
+AM_LDFLAGS = -module -avoid-version \
+ -export-symbols-regex \(PyInit__\|init_\)dbus_bindings \
$(DBUS_LIBS)
_dbus_bindings_la_SOURCES = \
abstract.c \