summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2007-01-16 19:52:45 +0000
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2007-01-16 19:52:45 +0000
commit47860b5c25c823587e4e06636acc926b252fe114 (patch)
tree3f1b75023ce6ba31a444e06af1d1b008fb432c78 /Makefile.am
parent916df7703d828afec95635d309ca83bc1c05fd98 (diff)
downloaddbus-python-47860b5c25c823587e4e06636acc926b252fe114.tar.gz
Add regression test for main loop failure handling (a main loop that never works)
Also run tests with DBUS_FATAL_WARNINGS and ulimit -c unlimited so they dump core at the slightest provocation.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 6f01a1e..43264c1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,6 +19,7 @@ EXTRA_DIST = API_CHANGES.txt dbus-python.pc.in HACKING.txt \
test/test-service.py \
test/test-signals.py \
test/test-standalone.py \
+ test/test-unusable-main-loop.py \
test/TestSuitePythonService.service.in \
test/tmp-session-bus.conf.in
# miss out the gconf examples for now - they don't work
@@ -47,7 +48,8 @@ nobase_python_PYTHON = dbus_bindings.py \
# === Python C extensions ===
-pyexec_LTLIBRARIES = _dbus_bindings.la _dbus_glib_bindings.la
+pyexec_LTLIBRARIES = _dbus_bindings.la _dbus_glib_bindings.la \
+ dbus_py_test.la
_dbus_bindings_la_CPPFLAGS = -I$(srcdir)/include \
$(DBUS_CFLAGS) \
$(PYTHON_INCLUDES)
@@ -91,6 +93,13 @@ _dbus_glib_bindings_la_LDFLAGS = -module -avoid-version \
_dbus_glib_bindings_la_SOURCES = _dbus_glib_bindings/module.c \
include/dbus-python.h
+dbus_py_test_la_CPPFLAGS = -I$(top_srcdir)/include $(DBUS_CFLAGS) \
+ $(PYTHON_INCLUDES)
+dbus_py_test_la_LDFLAGS = -module -avoid-version \
+ $(DBUS_LIBS)
+dbus_py_test_la_SOURCES = test/dbus_py_test.c \
+ include/dbus-python.h
+
# === Tests ===
PWD = `pwd`