summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorEwout ter Hoeven <E.M.terHoeven@student.tudelft.nl>2022-10-05 20:10:51 +0200
committerGitHub <noreply@github.com>2022-10-05 19:10:51 +0100
commit4215f740ab84975078fc0e98d33c55cc5b891f2e (patch)
tree06ae96665efeb4c1265807eee9f7407a1473ff3a /setup.py
parent25c0aa4b3536b6307a3b66f65cad702ed0f33e06 (diff)
downloadcython-4215f740ab84975078fc0e98d33c55cc5b891f2e.tar.gz
setup.py: Add project_urls for PyPI (#5064)
Add project_urls dictionary to setup.py with URLs to the Cython documentation, funding, source code and bug tracker. This will add those URLs under the "Project links" section on https://pypi.org/project/cython, making it easy to find these resources directly from PyPI.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py7
1 files changed, 7 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 1398c1574..26beca2f4 100755
--- a/setup.py
+++ b/setup.py
@@ -298,6 +298,13 @@ def run_build():
"Topic :: Software Development :: Compilers",
"Topic :: Software Development :: Libraries :: Python Modules"
],
+ project_urls={
+ "Documentation": "https://cython.readthedocs.io/",
+ "Donate": "https://cython.readthedocs.io/en/latest/src/donating.html",
+ "Source Code": "https://github.com/cython/cython",
+ "Bug Tracker": "https://github.com/cython/cython/issues",
+ "User Group": "https://groups.google.com/g/cython-users",
+ },
scripts=scripts,
packages=packages,