summaryrefslogtreecommitdiff
path: root/tests/server/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/server/Makefile.am')
-rw-r--r--tests/server/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/tests/server/Makefile.am b/tests/server/Makefile.am
index e274c01ab..620403815 100644
--- a/tests/server/Makefile.am
+++ b/tests/server/Makefile.am
@@ -5,7 +5,7 @@
# | (__| |_| | _ <| |___
# \___|\___/|_| \_\_____|
#
-# Copyright (C) 1998 - 2016, Daniel Stenberg, <daniel@haxx.se>, et al.
+# Copyright (C) 1998 - 2017, Daniel Stenberg, <daniel@haxx.se>, et al.
#
# This software is licensed as described in the file COPYING, which
# you should have received as part of this distribution. The terms
@@ -64,3 +64,8 @@ EXTRA_DIST = base64.pl Makefile.inc CMakeLists.txt
checksrc:
@PERL@ $(top_srcdir)/lib/checksrc.pl $(srcdir)/*.c
+
+if CURLDEBUG
+# for debug builds, we scan the sources on all regular make invokes
+all-local: checksrc
+endif