summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 081fb6d6d..227a54bd5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -594,6 +594,15 @@ fi
if test "$HAVE_GETHOSTBYNAME" != "1"
then
+ dnl gethostbyname in the network lib - for Haiku OS
+ AC_CHECK_LIB(network, gethostbyname,
+ [HAVE_GETHOSTBYNAME="1"
+ LIBS="$LIBS -lnetwork"
+ ])
+fi
+
+if test "$HAVE_GETHOSTBYNAME" != "1"
+then
dnl gethostbyname in the net lib - for BeOS
AC_CHECK_LIB(net, gethostbyname,
[HAVE_GETHOSTBYNAME="1"