summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 9dffa6b2f..dc8e416e4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2541,10 +2541,11 @@ if test X"$want_h2" != Xno; then
LDFLAGS="$LDFLAGS $LD_H2"
CPPFLAGS="$CPPFLAGS $CPP_H2"
LIBS="$LIB_H2 $LIBS"
+ LIB_H2_NAME=${LIB_H2#"-l"}
# use nghttp2_session_set_local_window_size to require nghttp2
# >= 1.12.0
- AC_CHECK_LIB(nghttp2, nghttp2_session_set_local_window_size,
+ AC_CHECK_LIB($LIB_H2_NAME, nghttp2_session_set_local_window_size,
[
AC_CHECK_HEADERS(nghttp2/nghttp2.h,
curl_h2_msg="enabled (nghttp2)"