summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac17
1 files changed, 3 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index cf4b5278f..496c18859 100755
--- a/configure.ac
+++ b/configure.ac
@@ -2228,26 +2228,15 @@ if test "$GNUTLS_ENABLED" = "1"; then
USE_GNUTLS_NETTLE=
# First check if we can detect either crypto library via transitive linking
AC_CHECK_LIB(gnutls, nettle_MD5Init, [ USE_GNUTLS_NETTLE=1 ])
- if test "$USE_GNUTLS_NETTLE" = ""; then
- AC_CHECK_LIB(gnutls, gcry_control, [ USE_GNUTLS_NETTLE=0 ])
- fi
+
# If not, try linking directly to both of them to see if they are available
if test "$USE_GNUTLS_NETTLE" = ""; then
AC_CHECK_LIB(nettle, nettle_MD5Init, [ USE_GNUTLS_NETTLE=1 ])
fi
if test "$USE_GNUTLS_NETTLE" = ""; then
- AC_CHECK_LIB(gcrypt, gcry_control, [ USE_GNUTLS_NETTLE=0 ])
- fi
- if test "$USE_GNUTLS_NETTLE" = ""; then
- AC_MSG_ERROR([GnuTLS found, but neither gcrypt nor nettle found])
- fi
- if test "$USE_GNUTLS_NETTLE" = "1"; then
- AC_DEFINE(USE_GNUTLS_NETTLE, 1, [if GnuTLS uses nettle as crypto backend])
- AC_SUBST(USE_GNUTLS_NETTLE, [1])
- LIBS="-lnettle $LIBS"
- else
- LIBS="-lgcrypt $LIBS"
+ AC_MSG_ERROR([GnuTLS found, but nettle was not found])
fi
+ LIBS="-lnettle $LIBS"
fi
dnl ---