summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index e759fe3af..71e530277 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -48,6 +48,15 @@ pdf:
check: test
+if CROSSCOMPILING
+test-full: test
+test-torture: test
+
+test:
+ @echo "NOTICE: we can't run the tests when cross-compiling!"
+
+else
+
test:
@(cd tests; $(MAKE) all quiet-test)
@@ -57,6 +66,8 @@ test-full:
test-torture:
@(cd tests; $(MAKE) all torture-test)
+endif
+
#
# Build source and binary rpms. For rpm-3.0 and above, the ~/.rpmmacros
# must contain the following line: