summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorMarc Hoersken <info@marc-hoersken.de>2021-09-27 21:17:29 +0200
committerMarc Hoersken <info@marc-hoersken.de>2021-10-08 20:16:15 +0200
commitab1671cafefcaf19ff6ac00a6cc7b36dfe16adcd (patch)
treee7b57626ec198036af2f0f562e994182c1df2909 /tests/Makefile.am
parentaceff6088cef70843de1da1dd7cc03c37c094d99 (diff)
downloadcurl-ab1671cafefcaf19ff6ac00a6cc7b36dfe16adcd.tar.gz
CI/makefiles: introduce dedicated test target
Make it easy to use the same set of test flags throughout all current and future CI builds. Reviewed-by: Jay Satiro Follow up to #7690 Closes #7785
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 8f47bb017..6e72e6294 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -71,6 +71,9 @@ TEST_E = -a -e
# !flaky means that it'll skip all tests using the flaky keyword
TEST_NF = -a -p !flaky
+
+# special CI target derived from nonflaky with CI-specific flags
+TEST_CI = $(TEST_NF) -r -rm -u
endif
# make sure that PERL is pointing to an executable
@@ -86,6 +89,9 @@ quiet-test: perlcheck all
am-test: perlcheck all
$(TEST) $(TEST_AM) $(TFLAGS)
+ci-test: perlcheck all
+ $(TEST) $(TEST_CI) $(TFLAGS)
+
full-test: perlcheck all
$(TEST) $(TEST_F) $(TFLAGS)