summaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Wu <peter@lekensteyn.nl>2014-10-13 00:00:39 +0200
committerDaniel Stenberg <daniel@haxx.se>2014-10-13 11:50:21 +0200
commit476499c75c83ffa3d65da398b5759a5f2fdb980d (patch)
tree58b04a3961543e4f56f18753a2e8d5615b784467 /tests/CMakeLists.txt
parentaec7c5a87c8482b6ddffa352d7d220698652262e (diff)
downloadcurl-476499c75c83ffa3d65da398b5759a5f2fdb980d.tar.gz
tests: move TESTCASES to Makefile.inc, add show for cmake
This change allows runtests.pl to be run from the CMake builddir: export srcdir=/tmp/curl/tests; perl -I$srcdir $srcdir/runtests.pl -l In order to make this possible, all test cases have been moved from Makefile.am to Makefile.inc. Signed-off-by: Peter Wu <peter@lekensteyn.nl>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 04ab06ed6..acd9caa00 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -1,2 +1,3 @@
+add_subdirectory(data)
add_subdirectory(libtest)
add_subdirectory(server)