summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2004-04-25 08:13:07 +0000
committerDaniel Stenberg <daniel@haxx.se>2004-04-25 08:13:07 +0000
commit68a3cbe38481f82e7776ddff413b832e1b41e45e (patch)
tree43ba7c37359b14871c2cdbc7404aa58d48178320 /src/Makefile.am
parentb9432d12965742ab13ed0a0f0462a9fa71e7b30d (diff)
downloadcurl-68a3cbe38481f82e7776ddff413b832e1b41e45e.tar.gz
make the generated hugehelp.c file use the USE_MANUAL define so that it
will be properly built with configure --disable-manual even if the source file is already present
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index a83309725..c5af70251 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -74,7 +74,10 @@ $(HUGE): $(README) $(MANPAGE) mkhelp.pl
else # HAVE_LIBZ
# This generates the hugehelp.c file uncompressed only
$(HUGE): $(README) $(MANPAGE) mkhelp.pl
- $(NROFF) $(MANPAGE) | $(PERL) $(MKHELP) $(README) > $(HUGE)
+ echo '#ifdef HAVE_CONFIG_H' > $(HUGE)
+ echo '#include "config.h"' >> $(HUGE)
+ echo '#endif' >> $(HUGE)
+ $(NROFF) $(MANPAGE) | $(PERL) $(MKHELP) $(README) >> $(HUGE)
endif
else # USE_MANUAL