summaryrefslogtreecommitdiff
path: root/packages/Makefile.am
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2020-10-15 10:07:00 +0200
committerJay Satiro <raysatiro@yahoo.com>2020-10-17 23:33:50 -0400
commitf3b7d72c57ed84189ce6e1ca3426e9681236ddf2 (patch)
tree9744b5c6bf1a6f59657ca7fc52d05187851a5407 /packages/Makefile.am
parent3bcd81df925d47d1b877a918a3665cdd551d9248 (diff)
downloadcurl-f3b7d72c57ed84189ce6e1ca3426e9681236ddf2.tar.gz
packages/OS400: make the source code-style compliant
... and make sure 'make checksrc' in the root dir also verifies the packages/OS400 sources. Closes https://github.com/curl/curl/pull/6085
Diffstat (limited to 'packages/Makefile.am')
-rw-r--r--packages/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/packages/Makefile.am b/packages/Makefile.am
index 0fc585629..3e0cea64c 100644
--- a/packages/Makefile.am
+++ b/packages/Makefile.am
@@ -41,3 +41,11 @@ EXTRA_DIST = README \
TPF/maketpf.env_curl \
TPF/maketpf.env_curllib \
Android/Android.mk
+
+CHECKSRC = $(CS_$(V))
+CS_0 = @echo " RUN " $@;
+CS_1 =
+CS_ = $(CS_0)
+
+checksrc:
+ $(CHECKSRC)(@PERL@ $(top_srcdir)/lib/checksrc.pl -D$(srcdir) $(srcdir)/OS400/*.[ch])