summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2013-12-17 23:05:37 +0100
committerDaniel Stenberg <daniel@haxx.se>2013-12-20 17:12:42 +0100
commiteccf4fb7eee33c0d011bd90449ff1c162dc87c1b (patch)
tree46864bfa55107166ea3ac53d5c8b9974bd61ad84 /lib/Makefile.am
parent9f260b5d6610f3845e811146e4197700a6cc7b6b (diff)
downloadcurl-eccf4fb7eee33c0d011bd90449ff1c162dc87c1b.tar.gz
vtls: created subdir, moved sslgen.[ch] there, updated all include lines
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am13
1 files changed, 4 insertions, 9 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 4477cc25f..6dffbd9c9 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -60,20 +60,15 @@ CFLAGS += @CURL_CFLAG_EXTRAS@
# $(top_builddir)/ares is for in-tree c-ares's generated ares_build.h file
# $(top_srcdir)/ares is for in-tree c-ares's external include files
-if USE_EMBEDDED_ARES
-AM_CPPFLAGS = -I$(top_builddir)/include/curl \
- -I$(top_builddir)/include \
- -I$(top_srcdir)/include \
- -I$(top_builddir)/lib \
- -I$(top_srcdir)/lib \
- -I$(top_builddir)/ares \
- -I$(top_srcdir)/ares
-else
AM_CPPFLAGS = -I$(top_builddir)/include/curl \
-I$(top_builddir)/include \
-I$(top_srcdir)/include \
-I$(top_builddir)/lib \
-I$(top_srcdir)/lib
+
+if USE_EMBEDDED_ARES
+AM_CPPFLAGS += -I$(top_builddir)/ares \
+ -I$(top_srcdir)/ares
endif
# Prevent LIBS from being used for all link targets