summaryrefslogtreecommitdiff
path: root/docs/Makefile.am
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2002-10-14 07:39:49 +0000
committerDaniel Stenberg <daniel@haxx.se>2002-10-14 07:39:49 +0000
commite6367abae97f15dd6dca65a493c6037e9e5d47b3 (patch)
treeb63e03ac8b971a41635efe84fd7f057e91e567fb /docs/Makefile.am
parentfc4d1d9a60d42366c8d79847999da2f25ff27510 (diff)
downloadcurl-e6367abae97f15dd6dca65a493c6037e9e5d47b3.tar.gz
generate and include PDF versions of the docs in the release archive
Diffstat (limited to 'docs/Makefile.am')
-rw-r--r--docs/Makefile.am18
1 files changed, 16 insertions, 2 deletions
diff --git a/docs/Makefile.am b/docs/Makefile.am
index 1c34a8c8d..7b3fa1339 100644
--- a/docs/Makefile.am
+++ b/docs/Makefile.am
@@ -12,16 +12,20 @@ HTMLPAGES = \
curl.html \
curl-config.html
+PDFPAGES = \
+ curl.pdf \
+ curl-config.pdf
+
SUBDIRS = examples libcurl
EXTRA_DIST = MANUAL BUGS CONTRIBUTE FAQ FEATURES INTERNALS \
README.win32 RESOURCES TODO TheArtOfHttpScripting THANKS \
VERSIONS KNOWN_BUGS BINDINGS $(man_MANS) $(HTMLPAGES) \
- HISTORY INSTALL libcurl-the-guide
+ HISTORY INSTALL libcurl-the-guide $(PDFPAGES)
MAN2HTML= gnroff -man $< | man2html >$@
-SUFFIXES = .1 .3 .html
+SUFFIXES = .1 .3 .html .pdf
html: $(HTMLPAGES)
cd libcurl; make html
@@ -31,3 +35,13 @@ html: $(HTMLPAGES)
.1.html:
$(MAN2HTML)
+
+MAN2PDF = groff -Tps -man curl.1 $< >$@
+
+pdf:
+ for file in $(man_MANS); do \
+ foo=`echo $$file | sed -e 's/\.[0-9]$$//g'`; \
+ groff -Tps -man $$file >$$foo.ps; \
+ ps2pdf $$foo.ps $$foo.pdf; \
+ done
+ cd libcurl; make pdf