summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authortoddouska <todd@yassl.com>2011-12-27 12:17:37 -0800
committerDaniel Stenberg <daniel@haxx.se>2012-02-14 19:49:54 +0100
commitee7e4fc1d1d45713e9e67a955e78f0d9ed1a6059 (patch)
tree876558e53eb54423b3da8a2d4bf504c4ccf5ba82 /configure.ac
parent020128053379ba5baa41bc2f72c391f6fcfbdf29 (diff)
downloadcurl-ee7e4fc1d1d45713e9e67a955e78f0d9ed1a6059.tar.gz
cyassl: update to CyaSSL 2.0.x API
Modify configure.ac to test for new CyaSSL Init function and remove default install path to system. Change to CyaSSL OpenSSL header and proper Init in code as well. Note that this no longer detects or works with CyaSSL before v2
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 4 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 6dfb4dd40..631563dea 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1957,7 +1957,7 @@ OPT_CYASSL=no
_cppflags=$CPPFLAGS
_ldflags=$LDFLAGS
AC_ARG_WITH(cyassl,dnl
-AC_HELP_STRING([--with-cyassl=PATH],[where to look for CyaSSL, PATH points to the installation root (default: /usr/local/cyassl)])
+AC_HELP_STRING([--with-cyassl=PATH],[where to look for CyaSSL, PATH points to the installation root (default: system lib default)])
AC_HELP_STRING([--without-cyassl], [disable CyaSSL detection]),
OPT_CYASSL=$withval)
@@ -1970,14 +1970,9 @@ if test "$OPENSSL_ENABLED" != "1"; then
fi
if test -z "$OPT_CYASSL" ; then
- dnl check for lib in default first
+ dnl check for lib in system default first
- trycyassldir="/usr/local/cyassl"
-
- LDFLAGS="$LDFLAGS -L$trycyassldir/lib"
- CPPFLAGS="$CPPFLAGS -I$trycyassldir/include"
-
- AC_CHECK_LIB(cyassl, InitCyaSSL,
+ AC_CHECK_LIB(cyassl, CyaSSL_Init,
dnl libcyassl found, set the variable
[
AC_DEFINE(USE_CYASSL, 1, [if CyaSSL is enabled])
@@ -1999,7 +1994,7 @@ if test "$OPENSSL_ENABLED" != "1"; then
CPPFLAGS="$CPPFLAGS $addcflags"
fi
- AC_CHECK_LIB(cyassl, InitCyaSSL,
+ AC_CHECK_LIB(cyassl, CyaSSL_Init,
[
AC_DEFINE(USE_CYASSL, 1, [if CyaSSL is enabled])
AC_SUBST(USE_CYASSL, [1])