summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPierre Chapuis <catwell@archlinux.us>2012-05-10 18:50:51 +0200
committerDaniel Stenberg <daniel@haxx.se>2012-05-12 23:46:06 +0200
commite315927a1ac34c286a22d8a54794ba15de82c589 (patch)
treef2c1402a3aa8f61edab8b6c77764f95c336ea57f /configure.ac
parent03c1bcf4bda7a493ea8020070cecdd5f0ed37c65 (diff)
downloadcurl-e315927a1ac34c286a22d8a54794ba15de82c589.tar.gz
autoconf: improve handling of versioned symbols
It checks whether versioned symbols should be enabled before checking whether it is possible (i.e. the linker supports --version-script) or not. This avoids a useless warning when building cURL on a platform that does not use GNU ld. Moreover, it fixes broken indentation of this chunk of code.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac50
1 files changed, 23 insertions, 27 deletions
diff --git a/configure.ac b/configure.ac
index 89f26f47a..966273d19 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2387,41 +2387,37 @@ dnl **********************************************************************
dnl Check for linker switch for versioned symbols
dnl **********************************************************************
-AC_MSG_CHECKING([if libraries can be versioned])
-GLD=`$LD --help < /dev/null 2>/dev/null | grep version-script`
-if test -z "$GLD"; then
- versioned_symbols_flavour=
- AC_MSG_RESULT(no)
- AC_MSG_WARN(***
-*** You need an ld version supporting the --version-script option.
-)
-else
- AC_MSG_RESULT(yes)
-
-AC_MSG_CHECKING([whether versioned symbols are wanted])
versioned_symbols_flavour=
-
+AC_MSG_CHECKING([whether versioned symbols are wanted])
AC_ARG_ENABLE(versioned-symbols,
AC_HELP_STRING([--enable-versioned-symbols], [Enable versioned symbols in shared library])
AC_HELP_STRING([--disable-versioned-symbols], [Disable versioned symbols in shared library]),
[ case "$enableval" in
yes) AC_MSG_RESULT(yes)
- if test "x$OPENSSL_ENABLED" = "x1"; then
- versioned_symbols_flavour="OPENSSL_"
- elif test "x$GNUTLS_ENABLED" == "x1"; then
- versioned_symbols_flavour="GNUTLS_"
- elif test "x$NSS_ENABLED" == "x1"; then
- versioned_symbols_flavour="NSS_"
- elif test "x$POLARSSL_ENABLED" == "x1"; then
- versioned_symbols_flavour="POLARSSL_"
- elif test "x$CYASSL_ENABLED" == "x1"; then
- versioned_symbols_flavour="CYASSL_"
- elif test "x$AXTLS_ENABLED" == "x1"; then
- versioned_symbols_flavour="AXTLS_"
+ AC_MSG_CHECKING([if libraries can be versioned])
+ GLD=`$LD --help < /dev/null 2>/dev/null | grep version-script`
+ if test -z "$GLD"; then
+ AC_MSG_RESULT(no)
+ AC_MSG_WARN([You need an ld version supporting the --version-script option])
else
- versioned_symbols_flavour=""
+ AC_MSG_RESULT(yes)
+ if test "x$OPENSSL_ENABLED" = "x1"; then
+ versioned_symbols_flavour="OPENSSL_"
+ elif test "x$GNUTLS_ENABLED" == "x1"; then
+ versioned_symbols_flavour="GNUTLS_"
+ elif test "x$NSS_ENABLED" == "x1"; then
+ versioned_symbols_flavour="NSS_"
+ elif test "x$POLARSSL_ENABLED" == "x1"; then
+ versioned_symbols_flavour="POLARSSL_"
+ elif test "x$CYASSL_ENABLED" == "x1"; then
+ versioned_symbols_flavour="CYASSL_"
+ elif test "x$AXTLS_ENABLED" == "x1"; then
+ versioned_symbols_flavour="AXTLS_"
+ else
+ versioned_symbols_flavour=""
+ fi
+ versioned_symbols="yes"
fi
- versioned_symbols="yes"
;;
*) AC_MSG_RESULT(no)