summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarcus Hoffmann <m.hoffmann@cartelsol.com>2017-01-11 14:42:41 +0100
committerDaniel Stenberg <daniel@haxx.se>2017-01-13 09:54:55 +0100
commit7ba8020c467936283661357d21fe142f2bc48933 (patch)
tree51fa6f05c12cb7013879c121546467c9b2e86512 /configure.ac
parent1d4202ade602dd4f1192c69aed5cc905e7a9b4e2 (diff)
downloadcurl-7ba8020c467936283661357d21fe142f2bc48933.tar.gz
gnutls: check for alpn and ocsp in configure
Check for presence of gnutls_alpn_* and gnutls_ocsp_* functions during configure instead of relying on the version number. GnuTLS has options to turn these features off and we ca just work with with such builds like we work with older versions. Signed-off-by: Marcus Hoffmann <m.hoffmann@cartelsol.com> Closes #1204
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 65dac55bc..fa44787ef 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1847,7 +1847,7 @@ if test "$curl_ssl_msg" = "$init_ssl_msg"; then
AC_MSG_NOTICE([Added $gtlslib to LD_LIBRARY_PATH])
fi
fi
- AC_CHECK_FUNCS(gnutls_certificate_set_x509_key_file2)
+ AC_CHECK_FUNCS([gnutls_certificate_set_x509_key_file2 gnutls_alpn_set_protocols gnutls_ocsp_req_init])
fi
fi