summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Hordijk <hordijk@aurora.tech>2021-03-09 15:04:06 -0500
committerDaniel Stenberg <daniel@haxx.se>2021-03-12 09:45:10 +0100
commitb3ace846425052b10126000289295e60763c520e (patch)
tree48bf8ef7aea65020f6ab9b9e29d44aae0aebf3a8 /configure.ac
parent21445a76dfadfcdd6ed3e0ae3bf4f198c5b8e84d (diff)
downloadcurl-b3ace846425052b10126000289295e60763c520e.tar.gz
configure: only add OpenSSL paths if they are defined
Add paths for OpenSSL compiling and linking only if they have been defined. If they haven't been defined, we'll assume that the paths are already available to the toolchain. Closes #6730
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index f3b11f005..a16804419 100755
--- a/configure.ac
+++ b/configure.ac
@@ -1834,8 +1834,10 @@ if test -z "$ssl_backends" -o "x$OPT_SSL" != xno &&
HAVECRYPTO="yes"
LIBS="-lcrypto $LIBS"
],[
- LDFLAGS="$CLEANLDFLAGS -L$LIB_OPENSSL"
- if test "$PKGCONFIG" = "no" ; then
+ if test -n "$LIB_OPENSSL" ; then
+ LDFLAGS="$CLEANLDFLAGS -L$LIB_OPENSSL"
+ fi
+ if test "$PKGCONFIG" = "no" -a -n "$PREFIX_OPENSSL" ; then
# only set this if pkg-config wasn't used
CPPFLAGS="$CLEANCPPFLAGS -I$PREFIX_OPENSSL/include/openssl -I$PREFIX_OPENSSL/include"
fi