summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2016-08-21 23:34:48 +0200
committerDaniel Stenberg <daniel@haxx.se>2016-08-21 23:34:48 +0200
commit95ded2c5691866d2ea86f673648777a677a30093 (patch)
treee8acb83b562709c107696fb0b39646c4dca9c747 /configure.ac
parentfba9dec5c53ac180ff253ff6087b9f07e33ad292 (diff)
downloadcurl-95ded2c5691866d2ea86f673648777a677a30093.tar.gz
configure: make it work without PKG_CHECK_MODULES
With commit c2f9b78 we added a new dependency on pkg-config for developers which may be unwanted. This change make the configure script still work as before if pkg-config isn't installed, it'll just use the old zlib detection logic without pkg-config. Reported-by: Marc Hörsken Fixes #972
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3c00ae107..5e769301e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -892,13 +892,16 @@ else
fi
if test -z "$OPT_ZLIB" ; then
- PKG_CHECK_MODULES([ZLIB], [zlib],
+
+ m4_ifdef([PKG_CHECK_MODULES], [
+ PKG_CHECK_MODULES([ZLIB], [zlib],
[ LIBS="${ZLIB_LIBS} $LIBS"
CPPFLAGS="${ZLIB_CFLAGS} $CPPFLAGS"
HAVE_LIBZ="1"
],
[
])
+ ])
if test -z "$HAVE_LIBZ"; then