summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2010-11-05 14:07:38 +0100
committerDaniel Stenberg <daniel@haxx.se>2010-11-05 14:07:38 +0100
commit95719fbea6acf52d03b17de742f16be8f1f0ce70 (patch)
tree00092046ba3080c7813dff31bd6d3155a83fe326 /configure.ac
parentfbf51696ef1435cf358943c671ac55944ccec26c (diff)
downloadcurl-95719fbea6acf52d03b17de742f16be8f1f0ce70.tar.gz
xattr: add configure check and #ifdefs
setxattr is a glibc call to set extended attributes, so configure now checks for it and the code is adapted to only build when the functionality is present.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 224ca2d58..893e53c0c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2349,6 +2349,7 @@ CURL_CHECK_FUNC_LOCALTIME_R
CURL_CHECK_FUNC_MEMRCHR
CURL_CHECK_FUNC_POLL
CURL_CHECK_FUNC_SETSOCKOPT
+CURL_CHECK_FUNC_SETXATTR
CURL_CHECK_FUNC_SIGACTION
CURL_CHECK_FUNC_SIGINTERRUPT
CURL_CHECK_FUNC_SIGNAL