summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorYang Tse <yangsita@gmail.com>2008-10-15 18:10:02 +0000
committerYang Tse <yangsita@gmail.com>2008-10-15 18:10:02 +0000
commitbe760bed7e544136eaa175f0fe58251da1ff6e41 (patch)
treee3920c485d2fe66920ece96bce0d1075e727b392 /configure.ac
parent357383159e9840c65a850e738dd95cf5fc02d67b (diff)
downloadcurl-be760bed7e544136eaa175f0fe58251da1ff6e41.tar.gz
Ensure that shell variable contents which have active meaning
to the shell echo command are not interpreted when trying to remove extra whitespace from shell variable content.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 9 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 25572cd7a..91b1a3f27 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2534,15 +2534,15 @@ AC_SUBST(SUPPORT_PROTOCOLS)
dnl squeeze whitespace out of some variables
-CFLAGS=`eval echo $CFLAGS`
-CPPFLAGS=`eval echo $CPPFLAGS`
-DEFS=`eval echo $DEFS`
-LDFLAGS=`eval echo $LDFLAGS`
-LIBS=`eval echo $LIBS`
-
-CURL_LIBS=`eval echo $CURL_LIBS`
-LIBCURL_LIBS=`eval echo $LIBCURL_LIBS`
-TEST_SERVER_LIBS=`eval echo $TEST_SERVER_LIBS`
+squeeze CFLAGS
+squeeze CPPFLAGS
+squeeze DEFS
+squeeze LDFLAGS
+squeeze LIBS
+
+squeeze CURL_LIBS
+squeeze LIBCURL_LIBS
+squeeze TEST_SERVER_LIBS
AC_CONFIG_FILES([Makefile \
docs/Makefile \