summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2008-09-29 21:46:04 +0000
committerDaniel Stenberg <daniel@haxx.se>2008-09-29 21:46:04 +0000
commitf3ab5d5500f81b052e215b60fe55dcf88fe6635f (patch)
treebe1cf923eeb5eca48d2e66404a0506ca92f874a2 /configure.ac
parent8f467b4288b69e0cd2355cdb8d4dd8356950e447 (diff)
downloadcurl-f3ab5d5500f81b052e215b60fe55dcf88fe6635f.tar.gz
- Daniel Egger provided a patch that allows you to disable proxy support in
libcurl to somewhat reduce the size of the binary. Run configure --disable-proxy.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9f724cef7..6e7bbff26 100644
--- a/configure.ac
+++ b/configure.ac
@@ -509,6 +509,22 @@ AC_HELP_STRING([--disable-ldaps],[Disable LDAPS support]),
AC_SUBST(CURL_DISABLE_LDAPS, [1])
)
+AC_MSG_CHECKING([whether to support proxiesy])
+AC_ARG_ENABLE(proxy,
+AC_HELP_STRING([--enable-proxy],[Enable proxy support])
+AC_HELP_STRING([--disable-proxy],[Disable proxy support]),
+[ case "$enableval" in
+ no)
+ AC_MSG_RESULT(no)
+ AC_DEFINE(CURL_DISABLE_PROXY, 1, [to disable proxies])
+ AC_SUBST(CURL_DISABLE_PROXY, [1])
+ ;;
+ *) AC_MSG_RESULT(yes)
+ ;;
+ esac ],
+ AC_MSG_RESULT(yes)
+)
+
AC_MSG_CHECKING([whether to support dict])
AC_ARG_ENABLE(dict,
AC_HELP_STRING([--enable-dict],[Enable DICT support])