summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorYang Tse <yangsita@gmail.com>2008-09-24 19:13:01 +0000
committerYang Tse <yangsita@gmail.com>2008-09-24 19:13:01 +0000
commit4d437416daee0f626988b8c056ae9cd22486c655 (patch)
treefa0c53d82e00e6ba7670c3fec8278a6cf773bbe3 /configure.ac
parent267b942383465f8d9ff193e4deaa0d383a09d6b7 (diff)
downloadcurl-4d437416daee0f626988b8c056ae9cd22486c655.tar.gz
HAVE_INET_PTON will only be defined when an IPv6 capable working
inet_pton function is available.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 1 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 1f66edbcb..42ceb73e3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2077,6 +2077,7 @@ CURL_CHECK_FUNC_GETSERVBYPORT_R
CURL_CHECK_FUNC_GMTIME_R
CURL_CHECK_FUNC_INET_NTOA_R
CURL_CHECK_FUNC_INET_NTOP
+CURL_CHECK_FUNC_INET_PTON
CURL_CHECK_FUNC_LOCALTIME_R
CURL_CHECK_FUNC_SIGACTION
CURL_CHECK_FUNC_STRCASECMP
@@ -2118,7 +2119,6 @@ AC_CHECK_FUNCS([basename \
getrlimit \
gettimeofday \
inet_addr \
- inet_pton \
perror \
pipe \
poll \
@@ -2186,15 +2186,6 @@ AC_CHECK_DECL(basename, ,
#endif
)
-AC_CHECK_DECL(inet_pton, ,
- AC_DEFINE(HAVE_NO_INET_PTON_PROTO, 1,
- [Defined if no inet_pton() prototype available]),
-[
-#ifdef HAVE_ARPA_INET_H
-#include <arpa/inet.h>
-#endif
-]
-)
dnl Check if the getnameinfo function is available
dnl and get the types of five of its arguments.