summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2011-12-06 14:22:45 +0100
committerDaniel Stenberg <daniel@haxx.se>2011-12-06 14:22:45 +0100
commit2b0e09b0f98e0f67417652dd7f4afd59bf895326 (patch)
tree1ee8919ecfb02e4004572ae2578b5c454da3a4a0 /configure.ac
parent361cd03d5861d3639bfcc6b5001f113a05a195cc (diff)
downloadcurl-2b0e09b0f98e0f67417652dd7f4afd59bf895326.tar.gz
OpenSSL: check for the SSLv2 function in configure
If no SSLv2 was detected in OpenSSL by configure, then we enforce the OPENSSL_NO_SSL2 define as it seems some people report it not being defined properly in the OpenSSL headers.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 94cdd8329..4bf25dcd8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1514,7 +1514,8 @@ if test X"$OPT_SSL" != Xno; then
RAND_egd \
ENGINE_cleanup \
CRYPTO_cleanup_all_ex_data \
- SSL_get_shutdown )
+ SSL_get_shutdown \
+ SSLv2_client_method )
dnl Make an attempt to detect if this is actually yassl's headers and
dnl OpenSSL emulation layer. We still leave everything else believing