summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2022-09-22 11:52:08 +0200
committerDaniel Stenberg <daniel@haxx.se>2022-09-22 23:06:26 +0200
commit935b1bd4544a23a91d68ffb9f86983e92747e9a5 (patch)
treeb31b3868b60c475dd60bc6d9195ecdf57d9c0614 /configure.ac
parentbf1571eb6ff24a8299da7da84408da31f0094f66 (diff)
downloadcurl-935b1bd4544a23a91d68ffb9f86983e92747e9a5.tar.gz
mprintf: use snprintf if available
This is the single place in libcurl code where it uses the "native" s(n)printf() function. Used for writing floats. The use has been reviewed and vetted and uses a HUGE target buffer, but switching to snprintf() still makes this safer and removes build-time warnings. Reported-by: Philip Heiduck Fixes #9569 Closes #9570
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1f114002b..9739eab2c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3535,6 +3535,7 @@ AC_CHECK_FUNCS([fnmatch \
setlocale \
setmode \
setrlimit \
+ snprintf \
utime \
utimes
],[