summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorOliver Urbann <oliver.urbann@tu-dortmund.de>2020-11-18 19:44:35 +0100
committerDaniel Stenberg <daniel@haxx.se>2020-11-20 23:36:51 +0100
commit0d16a49c16a868524a3e51d390b5ea106ce9b51c (patch)
tree92b755319484903a9ad5d458342f6e6bbf34a134 /configure.ac
parentc353207057b45c0e814823b5fe5eabeb4cc2d707 (diff)
downloadcurl-0d16a49c16a868524a3e51d390b5ea106ce9b51c.tar.gz
curl: add compatibility for Amiga and GCC 6.5
Changes are mainly reordering and adding of includes required to compile with a more recent version of GCC. Closes #6220
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 1075511c9..39bdb5ef1 100755
--- a/configure.ac
+++ b/configure.ac
@@ -863,14 +863,14 @@ then
])
fi
-if test "$HAVE_GETHOSTBYNAME" != "1"
+if test "$HAVE_GETHOSTBYNAME" != "1" -o "${with_amissl+set}" = set
then
dnl This is for AmigaOS with bsdsocket.library - needs testing before -lnet
AC_MSG_CHECKING([for gethostbyname for AmigaOS bsdsocket.library])
AC_LINK_IFELSE([
AC_LANG_PROGRAM([[
-#include <proto/bsdsocket.h>
-struct Library *SocketBase = NULL;
+ #include <proto/bsdsocket.h>
+ struct Library *SocketBase = NULL;
]],[[
gethostbyname("www.dummysite.com");
]])