summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorYang Tse <yangsita@gmail.com>2005-12-15 19:39:44 +0000
committerYang Tse <yangsita@gmail.com>2005-12-15 19:39:44 +0000
commit51581c034d2a56028b3da937fa809a490c13e168 (patch)
treef0d734df5738d1abee35ea213912f6c4714b53e5 /configure.ac
parent8f25a95b475e9ba3a5145a69fadf1f01879dc949 (diff)
downloadcurl-51581c034d2a56028b3da937fa809a490c13e168.tar.gz
Tests to check the availability of compilable and
valid windows.h winsock.h winsock2.h and ws2tcpip.h header files: CURL_CHECK_HEADER_WINDOWS CURL_CHECK_HEADER_WINSOCK CURL_CHECK_HEADER_WINSOCK2 CURL_CHECK_HEADER_WS2TCPIP
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index af7e62d0e..2de3128a7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -289,6 +289,22 @@ AC_HELP_STRING([--disable-manual],[Disable built-in manual]),
dnl The actual use of the USE_MANUAL variable is done much later in this
dnl script to allow other actions to disable it as well.
+dnl **********************************************************************
+dnl Make sure that our checks for headers windows.h winsock.h winsock2.h
+dnl and ws2tcpip.h take precedence over any other further check done later.
+dnl **********************************************************************
+
+dnl Do we have a compilable and valid windows.h header ?
+CURL_CHECK_HEADER_WINDOWS
+
+dnl Do we have a compilable and valid winsock.h header ?
+CURL_CHECK_HEADER_WINSOCK
+
+dnl Do we have a compilable and valid winsock2.h header ?
+CURL_CHECK_HEADER_WINSOCK2
+
+dnl Do we have a compilable and valid ws2tcpip.h header ?
+CURL_CHECK_HEADER_WS2TCPIP
dnl **********************************************************************
dnl Checks for libraries.