summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWouter Van Rooy <wouter.van.rooy@vasco.com>2013-04-16 15:40:00 +0200
committerDaniel Stenberg <daniel@haxx.se>2013-04-16 16:07:41 +0200
commit68e7fb499d93ffcad8b7407c07689c8a5b1628b2 (patch)
treeb3e26ba8845279d103064fb5595e97f9a3b80e8e /configure.ac
parentd9569720dd67ba34be18fd0c9898d9002adedd40 (diff)
downloadcurl-68e7fb499d93ffcad8b7407c07689c8a5b1628b2.tar.gz
curl-config: don't output static libs when they are disabled
Curl-config outputs static libraries even when they are disabled in configure. This causes problems with the build of pycurl.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1a46fd9c2..49309e6f4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3350,6 +3350,11 @@ dnl yes or no
ENABLE_SHARED="$enable_shared"
AC_SUBST(ENABLE_SHARED)
+dnl to let curl-config output the static libraries correctly
+ENABLE_STATIC="$enable_static"
+AC_SUBST(ENABLE_STATIC)
+
+
dnl
dnl For keeping supported features and protocols also in pkg-config file
dnl since it is more cross-compile friendly than curl-config