summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorOkhin Vasilij <OkhinVI@gmail.com>2016-11-25 16:27:22 +0700
committerDaniel Stenberg <daniel@haxx.se>2016-11-26 17:28:53 +0100
commita4b2f7aafde33c2ab810adb6c3d119c9a0b824e7 (patch)
treeaad341f638c47257403729f86cf54834147431fb /configure.ac
parente38fe7abbf127c50b846a4456835dd2c1be631a5 (diff)
downloadcurl-a4b2f7aafde33c2ab810adb6c3d119c9a0b824e7.tar.gz
curl_version_info: add CURL_VERSION_HTTPS_PROXY
Closes #1142
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5a8057f61..7eff485b7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3710,6 +3710,11 @@ if test "x$USE_NGHTTP2" = "x1"; then
SUPPORT_FEATURES="$SUPPORT_FEATURES HTTP2"
fi
+if test "x$OPENSSL_ENABLED" = "x1" -o "x$GNUTLS_ENABLED" = "x1" \
+ -o "x$NSS_ENABLED" = "x1"; then
+ SUPPORT_FEATURES="$SUPPORT_FEATURES HTTPS-proxy"
+fi
+
AC_SUBST(SUPPORT_FEATURES)
dnl For supported protocols in pkg-config file