summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKevin Burke <kevin@burke.dev>2021-11-02 22:14:02 -0700
committerDaniel Stenberg <daniel@haxx.se>2021-11-11 13:47:25 +0100
commitb7757c2b811927ed45588c2ef1a48ab60f11516d (patch)
tree4f86b3cab77c6c559ea6982ce457d94a762cbf2f /configure.ac
parenteed7473eebc37ebca98c1e5d72138e339e764d9d (diff)
downloadcurl-b7757c2b811927ed45588c2ef1a48ab60f11516d.tar.gz
vtls/rustls: update to compile with rustls-ffi v0.8.0
Some method names, as well as the generated library name, were changed in a recent refactoring. Further, change the default configuration instructions to check for Hyper in either "target/debug" or "target/release" - the latter contains an optimized build configuration. Fixes #7947 Closes #7948
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0c2384703..bbe15c058 100644
--- a/configure.ac
+++ b/configure.ac
@@ -672,7 +672,7 @@ if test X"$want_hyper" != Xno; then
LIB_HYPER="-lhyper -ldl -lpthread -lm"
if test X"$want_hyper" != Xdefault; then
CPP_HYPER=-I"$want_hyper_path/capi/include"
- LD_HYPER="-L$want_hyper_path/target/debug"
+ LD_HYPER="-L$want_hyper_path/target/release -L$want_hyper_path/target/debug"
fi
fi
if test -n "$LIB_HYPER"; then