summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2016-01-12 10:30:54 +0100
committerDaniel Stenberg <daniel@haxx.se>2016-01-12 10:30:54 +0100
commit4bed87f8fa9a4174c7459a8ee96434a2d6aa91c7 (patch)
treeab7a18c02f0f2967fc6817f562e92422444f5dd3 /configure.ac
parent3ea77f6addd1c49e2ea7e6dcbc5d1e39f119e088 (diff)
downloadcurl-4bed87f8fa9a4174c7459a8ee96434a2d6aa91c7.tar.gz
configure: assume IPv6 works when cross-compiled
The configure test uses AC_TRY_RUN to figure out if an ipv6 socket works, and testing like that doesn't work for cross-compiles. These days IPv6 support is widespread so a blind guess is probably more likely to be 'yes' than 'no' now. Further: anyone who cross-compiles can use configure's --disable-ipv6 to explicitly disable IPv6 and that also works for cross-compiles. Made happen after discussions in issue #594
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 7593e9609..d6d3466b8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5,7 +5,7 @@
# | (__| |_| | _ <| |___
# \___|\___/|_| \_\_____|
#
-# Copyright (C) 1998 - 2015, Daniel Stenberg, <daniel@haxx.se>, et al.
+# Copyright (C) 1998 - 2016, Daniel Stenberg, <daniel@haxx.se>, et al.
#
# This software is licensed as described in the file COPYING, which
# you should have received as part of this distribution. The terms
@@ -1101,8 +1101,8 @@ main()
ipv6=yes,
AC_MSG_RESULT(no)
ipv6=no,
- AC_MSG_RESULT(no)
- ipv6=no
+ AC_MSG_RESULT(yes)
+ ipv6=yes
))
if test "$ipv6" = "yes"; then