summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Fandrich <dan@coneharvesters.com>2014-02-17 09:40:49 +0100
committerDan Fandrich <dan@coneharvesters.com>2014-02-17 09:50:46 +0100
commit184c3e2d3767ed06c3d2f995a4b98e4ce2c7548f (patch)
treea8186736b0db77fda0e8af62bc60cbef80843298 /configure.ac
parentb04c158adfe535aca5ac19bae288dca80be6dbb4 (diff)
downloadcurl-184c3e2d3767ed06c3d2f995a4b98e4ce2c7548f.tar.gz
configure: Fix the --disable-crypto-auth option
It now disables NTLM and GSS authentication methods, and produces compilable code when SSL is enabled.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index dd309345d..9dc68664f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3249,6 +3249,7 @@ AC_HELP_STRING([--disable-crypto-auth],[Disable cryptographic authentication]),
no)
AC_MSG_RESULT(no)
AC_DEFINE(CURL_DISABLE_CRYPTO_AUTH, 1, [to disable cryptographic authentication])
+ CURL_DISABLE_CRYPTO_AUTH=1
;;
*) AC_MSG_RESULT(yes)
;;
@@ -3382,7 +3383,8 @@ fi
if test "x$USE_WINDOWS_SSPI" = "x1"; then
SUPPORT_FEATURES="$SUPPORT_FEATURES SSPI"
fi
-if test "x$CURL_DISABLE_HTTP" != "x1"; then
+if test "x$CURL_DISABLE_HTTP" != "x1" -a \
+ "x$CURL_DISABLE_CRYPTO_AUTH" != "x1"; then
if test "x$USE_SSLEAY" = "x1" -o "x$USE_WINDOWS_SSPI" = "x1" \
-o "x$GNUTLS_ENABLED" = "x1" -o "x$NSS_ENABLED" = "x1" \
-o "x$DARWINSSL_ENABLED" = "x1"; then