summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2008-05-26 15:09:28 +0000
committerDaniel Stenberg <daniel@haxx.se>2008-05-26 15:09:28 +0000
commitb97606f0b044abc9a299ef78e3096bf06dcd8870 (patch)
tree1ba65946001e1af49b8e195bbe453c5175ed9c94 /configure.ac
parentf26154bfa99cd53b8fb87589f7cf1bd8663d1da4 (diff)
downloadcurl-b97606f0b044abc9a299ef78e3096bf06dcd8870.tar.gz
Andreas Faerber and Scott McCreary made (lib)curl build for the Haiku OS
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 081fb6d6d..227a54bd5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -594,6 +594,15 @@ fi
if test "$HAVE_GETHOSTBYNAME" != "1"
then
+ dnl gethostbyname in the network lib - for Haiku OS
+ AC_CHECK_LIB(network, gethostbyname,
+ [HAVE_GETHOSTBYNAME="1"
+ LIBS="$LIBS -lnetwork"
+ ])
+fi
+
+if test "$HAVE_GETHOSTBYNAME" != "1"
+then
dnl gethostbyname in the net lib - for BeOS
AC_CHECK_LIB(net, gethostbyname,
[HAVE_GETHOSTBYNAME="1"