summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorYang Tse <yangsita@gmail.com>2008-05-09 16:31:51 +0000
committerYang Tse <yangsita@gmail.com>2008-05-09 16:31:51 +0000
commit19479ea0217c93fd2973168084d1bb724eb8a34f (patch)
treea8b59cbb90c38f93c414ec5bebee3c60bd5ae887 /configure.ac
parentd708ef6731445a84a3d0499a4b13fd09a0dd0520 (diff)
downloadcurl-19479ea0217c93fd2973168084d1bb724eb8a34f.tar.gz
Internal time differences now use monotonic time source if available.
This also implies the removal of the winmm.lib dependency for WIN32.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac31
1 files changed, 1 insertions, 30 deletions
diff --git a/configure.ac b/configure.ac
index 910a8d160..8a5988959 100644
--- a/configure.ac
+++ b/configure.ac
@@ -675,36 +675,6 @@ if test x$CURL_DISABLE_LDAP != x1 ; then
fi
dnl **********************************************************************
-dnl Check for the presence of the winmm library.
-dnl **********************************************************************
-
-case $host in
- *-*-cygwin*)
- dnl Under Cygwin, winmm exists but is not needed as WIN32 is not #defined
- dnl and gettimeofday() will be used regardless of the outcome of this test.
- dnl Skip this test, otherwise -lwinmm will be needlessly added to LIBS
- dnl (and recorded as such in the .la file, potentially affecting downstream
- dnl clients of the library.)
- ;;
- *)
- AC_MSG_CHECKING([for timeGetTime in winmm])
- my_ac_save_LIBS=$LIBS
- LIBS="-lwinmm $LIBS"
- AC_TRY_LINK([#include <windef.h>
- #include <mmsystem.h>
- ],
- [timeGetTime();],
- [ dnl worked!
- AC_MSG_RESULT([yes])
- ],
- [ dnl failed, restore LIBS
- LIBS=$my_ac_save_LIBS
- AC_MSG_RESULT(no)]
- )
- ;;
-esac
-
-dnl **********************************************************************
dnl Checks for IPv6
dnl **********************************************************************
@@ -2006,6 +1976,7 @@ AC_CHECK_FUNCS( strtoll \
strcmpi \
gethostbyaddr \
gettimeofday \
+ clock_gettime \
inet_addr \
inet_ntoa \
inet_pton \