summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authort.artikov <t.artikov@2gis.ru>2021-07-09 03:11:14 +0700
committerJay Satiro <raysatiro@yahoo.com>2021-07-16 13:34:39 -0400
commit29c7cf79e8b44cfe98306a41a766d10e98c13d2b (patch)
tree5d7ec4700f3566d13282fb7b0e12af473d077799 /configure.ac
parentbc035f5c9dc4e0387a615d2cc5914f37a90be1e2 (diff)
downloadcurl-29c7cf79e8b44cfe98306a41a766d10e98c13d2b.tar.gz
configure: fix nghttp2 library name for static builds
Don't hardcode the nghttp2 library name, because it can vary, be "nghttp2_static" for example. Fixes https://github.com/curl/curl/issues/7367 Closes https://github.com/curl/curl/pull/7368
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 9dffa6b2f..dc8e416e4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2541,10 +2541,11 @@ if test X"$want_h2" != Xno; then
LDFLAGS="$LDFLAGS $LD_H2"
CPPFLAGS="$CPPFLAGS $CPP_H2"
LIBS="$LIB_H2 $LIBS"
+ LIB_H2_NAME=${LIB_H2#"-l"}
# use nghttp2_session_set_local_window_size to require nghttp2
# >= 1.12.0
- AC_CHECK_LIB(nghttp2, nghttp2_session_set_local_window_size,
+ AC_CHECK_LIB($LIB_H2_NAME, nghttp2_session_set_local_window_size,
[
AC_CHECK_HEADERS(nghttp2/nghttp2.h,
curl_h2_msg="enabled (nghttp2)"