summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Shahaf <d.s@daniel.shahaf.name>2015-11-20 04:56:10 +0000
committerDaniel Stenberg <daniel@haxx.se>2015-11-24 22:22:01 +0100
commitbe0d4141af6de8380d24180eab316c898fcb27e1 (patch)
tree97ec45b8328f9f90619cd67692e74297c37b62f4 /configure.ac
parent40c349ada92865faadd0de92fa5dc0d50ba67eb3 (diff)
downloadcurl-be0d4141af6de8380d24180eab316c898fcb27e1.tar.gz
build: Install zsh completion
Fixes #534 Closes #537
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 26 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e51be4f93..4c14e382e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3031,6 +3031,31 @@ if test X"$want_h2" != Xno; then
fi
dnl **********************************************************************
+dnl Check for zsh completion path
+dnl **********************************************************************
+
+OPT_ZSH_FPATH=default
+AC_ARG_WITH(zsh-functions-dir,
+AC_HELP_STRING([--with-zsh-functions-dir=PATH],[Install zsh completions to PATH])
+AC_HELP_STRING([--without-zsh-functions-dir],[Do not install zsh completions]),
+ [OPT_ZSH_FPATH=$withval])
+case "$OPT_ZSH_FPATH" in
+ no)
+ dnl --without-zsh-functions-dir option used
+ ;;
+ default|yes)
+ dnl --with-zsh-functions-dir option used without path
+ ZSH_FUNCTIONS_DIR="$datarootdir/zsh/site-functions"
+ AC_SUBST(ZSH_FUNCTIONS_DIR)
+ ;;
+ *)
+ dnl --with-zsh-functions-dir option used with path
+ ZSH_FUNCTIONS_DIR="$withval"
+ AC_SUBST(ZSH_FUNCTIONS_DIR)
+ ;;
+esac
+
+dnl **********************************************************************
dnl Back to "normal" configuring
dnl **********************************************************************
@@ -3797,6 +3822,7 @@ AC_CONFIG_FILES([Makefile \
include/curl/Makefile \
src/Makefile \
lib/Makefile \
+ scripts/Makefile \
lib/libcurl.vers \
tests/Makefile \
tests/certs/Makefile \