summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2010-08-04 17:23:38 +0200
committerDaniel Stenberg <daniel@haxx.se>2010-08-04 18:29:13 +0200
commitf8cf037ecf67d4dc490e0e54fb2c691211e859ba (patch)
treeb1e25f66a563d18a7b199312392454b624ddd644 /configure.ac
parent6028fdb3053657ae0bd099b704eca0e108ed9b7d (diff)
downloadcurl-f8cf037ecf67d4dc490e0e54fb2c691211e859ba.tar.gz
SCP: send large files properly with new enough libssh2
libssh2 1.2.6 and later handle >32bit file sizes properly even on 32bit architectures and we make sure to use that ability. Reported by: Mikael Johansson Bug: http://curl.haxx.se/mail/lib-2010-08/0052.html
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 633f9e49a..fe57875d9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1984,7 +1984,9 @@ if test X"$OPT_LIBSSH2" != Xno; then
dnl libssh2_version is a post 1.0 addition
dnl libssh2_init and libssh2_exit were added in 1.2.5
- AC_CHECK_FUNCS( libssh2_version libssh2_init libssh2_exit)
+ dnl libssh2_scp_send64 was added in 1.2.6
+ AC_CHECK_FUNCS( libssh2_version libssh2_init libssh2_exit \
+ libssh2_scp_send64 )
LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$DIR_SSH2"
export LD_LIBRARY_PATH