summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Zitzmann <nick@chronosnet.com>2012-06-27 11:57:31 +0200
committerYang Tse <yangsita@gmail.com>2012-06-27 11:57:31 +0200
commit7aa95afadd39867dd95fd4f3df316f7e7decac7a (patch)
treecaf5354894c6a786fb5b5bb3fc5a60ab553575ae /configure.ac
parentdc7dc9786f43484ca422c2505880b832dea0f4f1 (diff)
downloadcurl-7aa95afadd39867dd95fd4f3df316f7e7decac7a.tar.gz
DarwinSSL: allow using NTLM authentication
Allow NTLM authentication when building using SecureTransport (Darwin) for SSL. This uses CommonCrypto, a cryptography library that ships with all versions of iOS and Mac OS X. It's like OpenSSL's libcrypto, except that it's missing a few less-common cyphers and doesn't have a big number data structure.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3c792cd27..da9f75e19 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3279,7 +3279,8 @@ if test "x$USE_WINDOWS_SSPI" = "x1"; then
fi
if test "x$CURL_DISABLE_HTTP" != "x1"; then
if test "x$USE_SSLEAY" = "x1" -o "x$USE_WINDOWS_SSPI" = "x1" \
- -o "x$GNUTLS_ENABLED" = "x1" -o "x$NSS_ENABLED" = "x1"; then
+ -o "x$GNUTLS_ENABLED" = "x1" -o "x$NSS_ENABLED" = "x1" \
+ -o "x$DARWINSSL_ENABLED" = "x1"; then
SUPPORT_FEATURES="$SUPPORT_FEATURES NTLM"
if test "x$NTLM_WB_ENABLED" = "x1"; then
SUPPORT_FEATURES="$SUPPORT_FEATURES NTLM_WB"