summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2020-08-14 15:45:08 +0200
committerDaniel Stenberg <daniel@haxx.se>2020-08-26 22:58:21 +0200
commitd854572ccc5f524ba48a158c2c26614def9e39e5 (patch)
tree2a957fda3e739572a12a8320d48444fe938ce4bf /configure.ac
parentce88e21c724d5a45a2c8c295734f65f75cf4ea79 (diff)
downloadcurl-d854572ccc5f524ba48a158c2c26614def9e39e5.tar.gz
socketpair: allow CURL_DISABLE_SOCKETPAIR
... to completely disable the use of socketpair Closes #5850
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 918003e02..0d3e4e103 100755
--- a/configure.ac
+++ b/configure.ac
@@ -4687,6 +4687,24 @@ AC_HELP_STRING([--disable-cookies],[Disable cookies support]),
)
dnl ************************************************************
+dnl disable socketpair
+dnl
+AC_MSG_CHECKING([whether to support socketpair])
+AC_ARG_ENABLE(socketpair,
+AC_HELP_STRING([--enable-socketpair],[Enable socketpair support])
+AC_HELP_STRING([--disable-socketpair],[Disable socketpair support]),
+[ case "$enableval" in
+ no)
+ AC_MSG_RESULT(no)
+ AC_DEFINE(CURL_DISABLE_SOCKETPAIR, 1, [to disable socketpair support])
+ ;;
+ *) AC_MSG_RESULT(yes)
+ ;;
+ esac ],
+ AC_MSG_RESULT(yes)
+)
+
+dnl ************************************************************
dnl disable HTTP authentication support
dnl
AC_MSG_CHECKING([whether to support HTTP authentication])