summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorYang Tse <yangsita@gmail.com>2011-08-27 06:31:18 +0200
committerYang Tse <yangsita@gmail.com>2011-08-27 06:31:18 +0200
commitb976d108f1beecff743f912f190ffc89f1ef9098 (patch)
treef3ef3290835f79bcfa51cac3c68f978739d4f2c5 /configure.ac
parentb4f6319cf77ca2642154bdac76d6729dde56dd8e (diff)
downloadcurl-b976d108f1beecff743f912f190ffc89f1ef9098.tar.gz
NTLM_WB: final congruency naming adjustments
Configure script option --enable-wb-ntlm-auth renamed to --enable-ntlm-wb Configure script option --disable-wb-ntlm-auth renamed to --disable-ntlm-wb Preprocessor symbol WINBIND_NTLM_AUTH_ENABLED renamed to NTLM_WB_ENABLED Preprocessor symbol WINBIND_NTLM_AUTH_FILE renamed to NTLM_WB_FILE Test harness env var CURL_NTLM_AUTH renamed to CURL_NTLM_WB_FILE Static function wb_ntlm_close renamed to ntlm_wb_cleanup Static function wb_ntlm_initiate renamed to ntlm_wb_init Static function wb_ntlm_response renamed to ntlm_wb_response
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 7fb9cbf56..64ee1b7a6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2816,9 +2816,9 @@ AC_HELP_STRING([--disable-crypto-auth],[Disable cryptographic authentication]),
AC_MSG_RESULT(yes)
)
-CURL_CHECK_OPTION_WINBIND_NTLM_AUTH
+CURL_CHECK_OPTION_NTLM_WB
-CURL_CHECK_WINBIND_NTLM_AUTH
+CURL_CHECK_NTLM_WB
dnl ************************************************************
dnl disable TLS-SRP authentication
@@ -2995,7 +2995,7 @@ if test "x$CURL_DISABLE_HTTP" != "x1"; then
if test "x$USE_SSLEAY" = "x1" -o "x$USE_WINDOWS_SSPI" = "x1" \
-o "x$GNUTLS_ENABLED" = "x1" -o "x$NSS_ENABLED" = "x1"; then
SUPPORT_FEATURES="$SUPPORT_FEATURES NTLM"
- if test "x$WINBIND_NTLM_AUTH_ENABLED" = "x1"; then
+ if test "x$NTLM_WB_ENABLED" = "x1"; then
SUPPORT_FEATURES="$SUPPORT_FEATURES NTLM_WB"
fi
fi