summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2020-10-22 12:29:21 +0200
committerDaniel Stenberg <daniel@haxx.se>2020-10-22 16:45:40 +0200
commit4bfca0a80763a1184a4ca489bf739abd5a5657c5 (patch)
tree747acb88ea3de6c836f65a346f92697350ca4baa /configure.ac
parent141e23d78974774217fc22671934d16499505890 (diff)
downloadcurl-4bfca0a80763a1184a4ca489bf739abd5a5657c5.tar.gz
libssh2: require version 1.0 or later
... and simplify the code accordingly. libssh2 version 1.0 was released in April 2009. Closes #6116
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 8676b4825..d4ccc268a 100755
--- a/configure.ac
+++ b/configure.ac
@@ -3062,7 +3062,8 @@ if test X"$OPT_LIBSSH2" != Xno; then
CPPFLAGS="$CPPFLAGS $CPP_SSH2"
LIBS="$LIB_SSH2 $LIBS"
- AC_CHECK_LIB(ssh2, libssh2_channel_open_ex)
+ dnl check for function added in libssh2 version 1.0
+ AC_CHECK_LIB(ssh2, libssh2_session_block_directions)
AC_CHECK_HEADERS(libssh2.h,
curl_ssh_msg="enabled (libSSH2)"