summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarc Hoersken <info@marc-hoersken.de>2021-03-28 20:46:54 +0200
committerDaniel Stenberg <daniel@haxx.se>2021-03-29 09:08:48 +0200
commitd6fba0ca06d4fb7d09d083fbbd260e49c0860e7d (patch)
tree9e7da5a38374f097c813c506844d70dbdb746105 /configure.ac
parentce2d5fb7fa9e52efe08201ba04099d8b177a9ef1 (diff)
downloadcurl-d6fba0ca06d4fb7d09d083fbbd260e49c0860e7d.tar.gz
config: fix SSPI enabling NTLM if crypto auth is disabled
Avoid enabling NTLM feature based upon Windows SSPI being enabled in case that crypto auth is disabled. Reported-by: Marcel Raad Follow-up to #6277 Fixes #6803 Closes #6808
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac28
1 files changed, 15 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index 6f8f1c0cc..f66248150 100755
--- a/configure.ac
+++ b/configure.ac
@@ -5225,23 +5225,25 @@ if test "x$CURL_DISABLE_CRYPTO_AUTH" != "x1" -a \
SUPPORT_FEATURES="$SUPPORT_FEATURES Kerberos"
fi
-if test "x$CURL_DISABLE_CRYPTO_AUTH" != "x1" -a \
- \( "x$OPENSSL_ENABLED" = "x1" -o "x$MBEDTLS_ENABLED" = "x1" \
+use_curl_ntlm_core=no
+
+if test "x$CURL_DISABLE_CRYPTO_AUTH" != "x1"; then
+ if test "x$OPENSSL_ENABLED" = "x1" -o "x$MBEDTLS_ENABLED" = "x1" \
-o "x$GNUTLS_ENABLED" = "x1" -o "x$NSS_ENABLED" = "x1" \
-o "x$SECURETRANSPORT_ENABLED" = "x1" \
-o "x$USE_WIN32_CRYPTO" = "x1" \
- -o "x$WOLFSSL_NTLM" = "x1" \); then
- use_curl_ntlm_core=yes
-else
- use_curl_ntlm_core=no
-fi
-if test "x$use_curl_ntlm_core" = "xyes" \
- -o "x$USE_WINDOWS_SSPI" = "x1"; then
- SUPPORT_FEATURES="$SUPPORT_FEATURES NTLM"
+ -o "x$WOLFSSL_NTLM" = "x1"; then
+ use_curl_ntlm_core=yes
+ fi
+
+ if test "x$use_curl_ntlm_core" = "xyes" \
+ -o "x$USE_WINDOWS_SSPI" = "x1"; then
+ SUPPORT_FEATURES="$SUPPORT_FEATURES NTLM"
- if test "x$CURL_DISABLE_HTTP" != "x1" -a \
- "x$NTLM_WB_ENABLED" = "x1"; then
- SUPPORT_FEATURES="$SUPPORT_FEATURES NTLM_WB"
+ if test "x$CURL_DISABLE_HTTP" != "x1" -a \
+ "x$NTLM_WB_ENABLED" = "x1"; then
+ SUPPORT_FEATURES="$SUPPORT_FEATURES NTLM_WB"
+ fi
fi
fi