summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2005-09-02 15:11:08 +0000
committerDaniel Stenberg <daniel@haxx.se>2005-09-02 15:11:08 +0000
commit56d9624b566ac15ffb4b4b6eef220a5000b767e0 (patch)
tree9511f37ced87ba79fe96416b21e41fadffe17224 /configure.ac
parent911d135deb619f6d18ae3e0150c3808be54831a3 (diff)
downloadcurl-56d9624b566ac15ffb4b4b6eef220a5000b767e0.tar.gz
John Kelly added TFTP support to libcurl. A bunch of new error codes was
added. TODO: add them to docs. add TFTP server to test suite. add TFTP to list of protocols whereever those are mentioned.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 494c2048a..1f2eedde3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -251,6 +251,21 @@ AC_HELP_STRING([--disable-telnet],[Disable TELNET support]),
esac ],
AC_MSG_RESULT(yes)
)
+AC_MSG_CHECKING([whether to support tftp])
+AC_ARG_ENABLE(tftp,
+AC_HELP_STRING([--enable-tftp],[Enable TFTP support])
+AC_HELP_STRING([--disable-tftp],[Disable TFTP support]),
+[ case "$enableval" in
+ no)
+ AC_MSG_RESULT(no)
+ AC_DEFINE(CURL_DISABLE_TFTP, 1, [to disable TFTP])
+ AC_SUBST(CURL_DISABLE_TFTP, [1])
+ ;;
+ *) AC_MSG_RESULT(yes)
+ ;;
+ esac ],
+ AC_MSG_RESULT(yes)
+)
dnl **********************************************************************
dnl Check for built-in manual