summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTatsuhiro Tsujikawa <tatsuhiro.t@gmail.com>2021-09-12 15:27:33 +0900
committerDaniel Stenberg <daniel@haxx.se>2021-09-12 12:34:32 +0200
commit24a7cbe9d22cb1783a33b94288b656191b0e4375 (patch)
treed54951264faf096320e67ccf310ec733fe65f41b /configure.ac
parentdbe693e76973a12dfe39466c10cd83922813feef (diff)
downloadcurl-24a7cbe9d22cb1783a33b94288b656191b0e4375.tar.gz
ngtcp2: fix build with ngtcp2 and nghttp3
ngtcp2_conn_client_new and nghttp3_conn_client_new are now macros. Check the wrapped functions instead. ngtcp2_stream_close callback now takes flags parameter. Closes #7709
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 34ec0efd3..152b0472e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2677,7 +2677,7 @@ if test X"$want_tcp2" != Xno; then
if test "x$cross_compiling" != "xyes"; then
DIR_TCP2=`echo $LD_TCP2 | $SED -e 's/^-L//'`
fi
- AC_CHECK_LIB(ngtcp2, ngtcp2_conn_client_new,
+ AC_CHECK_LIB(ngtcp2, ngtcp2_conn_client_new_versioned,
[
AC_CHECK_HEADERS(ngtcp2/ngtcp2.h,
NGTCP2_ENABLED=1
@@ -2876,7 +2876,7 @@ if test X"$want_nghttp3" != Xno; then
if test "x$cross_compiling" != "xyes"; then
DIR_NGHTTP3=`echo $LD_NGHTTP3 | $SED -e 's/^-L//'`
fi
- AC_CHECK_LIB(nghttp3, nghttp3_conn_client_new,
+ AC_CHECK_LIB(nghttp3, nghttp3_conn_client_new_versioned,
[
AC_CHECK_HEADERS(nghttp3/nghttp3.h,
curl_h3_msg="enabled (ngtcp2 + nghttp3)"