summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2009-08-24 11:38:59 +0000
committerDaniel Stenberg <daniel@haxx.se>2009-08-24 11:38:59 +0000
commit0cb6f3053ffc784eb7452c2311b536f4f798e946 (patch)
treea7daaaf77ca21d9266f8c3441d75cfaf2e500e80 /configure.ac
parent95c2b205a4e33eab9ea331428565109bde99c8a5 (diff)
downloadcurl-0cb6f3053ffc784eb7452c2311b536f4f798e946.tar.gz
- Marc de Bruin pointed out that configure --with-gnutls=PATH didn't work
properly and provided a fix. http://curl.haxx.se/bug/view.cgi?id=2843008
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 6 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 2c9f1d8e0..e5e58c657 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1571,12 +1571,13 @@ if test "$OPENSSL_ENABLED" != "1"; then
else
dnl this is with a given path, first check if there's a libgnutls-config
dnl there and if not, make an educated guess
- check=`$OPT_GNUTLS/libgnutls-config --version 2>/dev/null`
+ cfg=$OPT_GNUTLS/bin/libgnutls-config
+ check=`$cfg --version 2>/dev/null`
if test -n "$check"; then
- addlib=`$OPT_GNUTLS/libgnutls-config --libs`
- addcflags=`$OPT_GNUTLS/libgnutls-config --cflags`
- version=`$OPT_GNUTLS/libgnutls-config --version`
- gtlslib=`$OPT_GNUTLS/libgnutls-config --prefix`/lib$libsuff
+ addlib=`$cfg --libs`
+ addcflags=`$cfg --cflags`
+ version=`$cfg --version`
+ gtlslib=`$cfg --prefix`/lib$libsuff
else
dnl without pkg-config and libgnutls-config, we guess a lot!
addlib=-lgnutls