summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2011-04-12 22:10:29 +0200
committerDaniel Stenberg <daniel@haxx.se>2011-04-12 22:10:29 +0200
commitfde795894f9af996aff9f7f0bff7d15050d5f8e0 (patch)
tree9c48ef556c8e26676fe2f35dbb1d2e433de3d139 /configure.ac
parent6710970bcea14f57896b1fb0c90825b33061ef51 (diff)
downloadcurl-fde795894f9af996aff9f7f0bff7d15050d5f8e0.tar.gz
configure: libssh2 link fix without pkg-config
The script didn't properly add the -lssh2 link option when it enabled libssh2 linking where pkg-config isn't found. Reported by: Saqib Ali Bug: http://curl.haxx.se/mail/lib-2011-04/0054.html
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 08f30fa90..ba09f07b4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2161,6 +2161,7 @@ if test X"$OPT_LIBSSH2" != Xno; then
dnl if given with a prefix, we set -L and -I based on that
if test -n "$PREFIX_SSH2"; then
+ LIB_SSH2="-lssh2"
LD_SSH2=-L${PREFIX_SSH2}/lib$libsuff
CPP_SSH2=-I${PREFIX_SSH2}/include
DIR_SSH2=${PREFIX_SSH2}/lib$libsuff