summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorYang Tse <yangsita@gmail.com>2010-08-09 09:33:53 +0200
committerYang Tse <yangsita@gmail.com>2010-08-09 09:33:53 +0200
commitb24e87250241c97c23f7c71c0ab9de74e793b8cc (patch)
tree61adeb49f2cfb35d150a54da7527c18d4c25e552 /configure.ac
parent50a1d5ee1c127d76ea3316f86d53accb66bc0b22 (diff)
downloadcurl-b24e87250241c97c23f7c71c0ab9de74e793b8cc.tar.gz
build: don't build libhostname unless shared libcurl is built
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a43b2863a..d876bde32 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2461,6 +2461,13 @@ AM_CONDITIONAL(USE_MANUAL, test x"$USE_MANUAL" = x1)
CURL_CHECK_LIB_ARES
AM_CONDITIONAL(USE_EMBEDDED_ARES, test x$embedded_ares = xyes)
+if test "x$enable_shared" = "xyes"; then
+ build_libhostname=yes
+else
+ build_libhostname=no
+fi
+AM_CONDITIONAL(BUILD_LIBHOSTNAME, test x$tests_use_libhostname = xyes)
+
CURL_CHECK_OPTION_THREADED_RESOLVER
if test "x$want_thres" = xyes && test "x$want_ares" = xyes; then