summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2010-07-25 17:48:07 +0200
committerDaniel Stenberg <daniel@haxx.se>2010-07-25 17:48:07 +0200
commita13128596c37603a1001e5f18b5706aa52600b3a (patch)
tree1af93a47d91018950ff6355e90b99ba6300bab7d /configure.ac
parent6d2ccfed48558f171c2840c3aa479261050d084a (diff)
downloadcurl-a13128596c37603a1001e5f18b5706aa52600b3a.tar.gz
curl-config: --built-shared returns shared info
The curl-config now features a --built-shared command line option that will output 'yes' or 'no' depending if the build process was asked to build shared library/libraries or not. It is primarily made to offer more details to the test suite to know what kind of stunts it can expect to work.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b0530c496..633f9e49a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2653,6 +2653,10 @@ LIBS=$ALL_LIBS dnl LIBS is a magic variable that's used for every link
AM_CONDITIONAL(CROSSCOMPILING, test x$cross_compiling = xyes)
+dnl yes or no
+ENABLE_SHARED="$enable_shared"
+AC_SUBST(ENABLE_SHARED)
+
dnl
dnl For keeping supported features and protocols also in pkg-config file
dnl since it is more cross-compile frient than curl-config